Links

Professional Licensing - Browser Requirements - AOL Users

AOL Users
If you use AOL as your Internet Service Provider please do not use the AOL browser because it does not work well with the online system. Go ahead and log onto AOL, and then minimize the AOL browser window.

Internet Explorer 6.0, 7.0 or Firefox can be used for the Online Licensing System. If you already have one of these browsers on your computer please make sure you are using the correct version by checking the browser requirements page.

If you do not have Microsoft Internet Explorer 6.0, 7.0 or Firefox on your computer please download one of them using the links below:

Free Browsers:
Click here for Internet Explorer
Click here for Firefox

NOTE: Please remember to restart your computer once you have completed the installation.

Still having technical problems?
If you are still experiencing technical problems after going through all the steps above you can look at the problem reporting page for email information, or call us at (916) 574-8020. Assistance is available Monday-Friday, 8:00 a.m. - 4:30 p.m. (except Holidays).